A version for Ubuntu

any plan to make a version for ubuntu ?

Hi Stephen —

No near-term plans to work on an Ubuntu-specific version, but it shouldn’t be hard to do since ubuntu is built on debian, and so is raspian. Might just be a matter of updating some of the install scripts in cases where the Ubuntu repos use different package names. Have you tried installing it on ubuntu to see what happens?

I do hope to find time to get Openframe running on my Odroids which run Ubuntu, so if no one else gets to it maybe I’ll work on it at some point…

I just tried to get OpenFrame running on Ubuntu (inside VirtualBox on a Mac).
Doesn’t throw any obvious errors. Doesn’t work either. ^^

Connects with the web app. And when I push an image or shader it tries to start glslViewer but glslViewer fails with:

GLFW error 0x10008: X11: The DISPLAY environment variable is missing. 
ABORT: GLFW init failed

tried to set the variable via
export DISPLAY=:0.0

now I get

GLFW error 0x10008: X11: Failed to open display :0.0`
ABORT: GLFW init failed

seems to relate to: https://github.com/patriciogonzalezvivo/glslViewer/issues/141 I guess?

1 Like

if I start the gnome system GUI via systemctl start gdm.service
and afterwards start Openframe in a terminal window, glslViewer seems to start fine (but in a window) and shows the right content…

1 Like

tried installing the vlc-extension. pushing vlc-content crashes openframe though (under gnome as well as in the command line). throws

      throw er; // Unhandled 'error' event

Error: spawn cvlc ENOENT
    at exports._errnoException (util.js:1022:11)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:193:32)
    at onErrorNT (internal/child_process.js:359:16)
    at _combinedTickCallback (internal/process/next_tick.js:74:11)
    at process._tickCallback (internal/process/next_tick.js:98:9)

tried installing processing-extension.
after a few attempts, when I got extension not installed (even though I did right before), I get an

_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
(EE) Cannot establish any listening sockets - Make sure an X server isn't already running(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/home/USER/.local/share/xorg/Xorg.0.log" for additional information.
(EE) Server terminated with error (1). Closing log file.
X connection to :0 broken (explicit kill or server shutdown).

(under gnome)

(from command line)

1 Like

Thanks so much for trying all of these things @_fx! Please keep those results coming they are very useful.

Unfortunately, I’m still working on other parts of Openframe which I would like to finish first before joining with testing. But I’m more than happy to answer any questions and give advice where I can.

I don’t know too much about Xserver though, to be honest. So I don’t know if I’m really helpful here.

Next I would try binaries that exist for Ubuntu as well but don’t require Xserver. Run them from outside Openframe on the command line and see if that works.

VLC should be one of them. You could try to run:
cvlc --loop --no-video-title —quiet https://www.youtube.com/watch?v=kTn0li1q1O0
cvlc --loop --no-video-title —quiet https://file-examples.com/wp-content/uploads/2017/04/file_example_MP4_1920_18MG.mp4
… make sure VLC is installed. I’m not sure if it comes with Ubuntu.

If that works we can move on to the ones that require Xserver.

@_fx has tested the new desktop mode extensions in Ubuntu:

To sum it up, Ubuntu in desktop mode using the desktop extensions works except:

  • Website and Processing: @_fx could you please check if /usr/bin/chromium and /usr/bin/processing-java exist in your Ubuntu install?


processing-java was indeed not part of $PATH :see_no_evil:
it’s working now. but not fullscreen.

chromium was in $PATH though and can be started from command line.

but both are not in /usr/bin/ but /usr/local/bin/processing and /snap/bin/chromium

ok explicitly added another symlink to /usr/bin/chromium now it’s working

That’s great @_fx . Thanks for figuring this out. Should be easy to implement this and create Linux versions for those extensions.