Error: The server is not available

Hi!

Noob question, sorry. I’ve installed Openframe on my Raspberry Pi 3



but keep getting the message “server is not available” displayed when I run the command Openframe. I noticed on installation I get a few warnings of things that have not been able to install correctly (see attached pic). Can you please direct to where I can get a workaround and get the app to work?

Thanks!

RSS

Same. Openframe user for several years (daily) and it just stopped working two days ago. Thought it was a card glitch, so I reimaged and still nothing. Pinged a couple addresses and got returns, but launching openframe from the command line gives a server error.

Any thoughts from the devs?

Thanks

1 Like

Anybody? Nobody else is having this issue?

same here. Looks like I picked the wrong point in time to try out Openframe…

Same.
Took out of wall yesterday for maintenance and can’t get it to work again.
Re installed everything and now get offline error.

That’s a shame, it was a great project. I’ll keep checking here because I’d like to keep what was working well, but if it’s not up in a few days, I’ll move to another app. I’ve spotted a couple others that will work after a rebuild.

Same problem/error here for the last 2 days.
New install and got stuck at the end with the “server not available” error.
I tried with both a Pi3 and a Pi4, same result.
Desktop and command line.
Any ideas?
Thx

Which other app did you find? thx

Hey! Really sorry for the delay — the hosted Openframe server is loosely maintained as time allows! And sadly I haven’t had time to look into this yet. The API server is running, otherwise the web app wouldn’t load, so it seems as though there’s some other issue that’s blocking the frame controller from connecting :/. I’ll try to find time to look into it ASAP.

Did anyone try looking at the debug output? I think if you run DEBUG=* openframe when starting up you might get more detailed error info? Not certain, haven’t tried it or looked at what debug info is present.

1 Like

Also check the config file at ~/.openframe/.ofrc — it’s possible this has been corrupted. The “network” property should look like this if you’re using the hosted Openframe server:

 "network": {
    "api_base": "https://api.openframe.io",
    "app_base": "https://openframe.io"
  }

1 Like

Hi there! New user, I’m trying to set up Openframe on a Pi as an Xmas gift for my girlfriend, but am encountering the “The server is not available” error as well.

I ran the DEBUG=* openframe command and got the following readout

openframe:cli Can’t read from server. It may not have the appropriate access-control-origin settings. +150ms

Hopefully this helps, trying to have this bad boy finished in the next few days!

Same issue here:

pi@raspberrypi:~ $ DEBUG=* openframe
  openframe:config load +0ms
  openframe:frame load +71ms
  openframe:frame inflateStateFromFile +33ms
  openframe:user load +17ms
  superagent GET https://api.openframe.io/explorer/swagger.json +458ms


[o]   ERROR: The server is not available.


  openframe:cli Can't read from server.  It may not have the appropriate access-control-origin settings. +430ms
pi@raspberrypi:~ $ cat ~/.openframe/
autoboot.sh  .ofrc
pi@raspberrypi:~ $ cat ~/.openframe/.ofrc
{
  "network": {
    "api_base": "https://api.openframe.io",
    "app_base": "https://openframe.io"
  }
}
pi@raspberrypi:~ $ ping api.openframe.io
PING api.openframe.io (138.197.95.128) 56(84) bytes of data.
64 bytes from 138.197.95.128 (138.197.95.128): icmp_seq=1 ttl=51 time=33.1 ms
64 bytes from 138.197.95.128 (138.197.95.128): icmp_seq=2 ttl=51 time=16.2 ms
64 bytes from 138.197.95.128 (138.197.95.128): icmp_seq=3 ttl=51 time=23.6 ms

I wonder if anything on the server has changed or been updated recently?

The issue definately seems to be CORS related on the server hosting the swagger.json.

I was able to setup a CORS Header Proxy using a CloudFlare worker - it adds the Access-Control-Allow-Origin header to the response. Once I changed the URL’s in.ofrc it was able to proceed past the failure.

Hello,
Could you explain please how you did that, i’m having the same error and can’t fix it i tried everything.

Thanks

So you’re going to need a Cloudflare account and a domain name attached.

I created a new worker to proxy HTTP requests using this code: gist:c08438dc64aab1ca820ccd181dc355b3 · GitHub

Then you need to modify .ofrc to look something like this:

{
  "network": {
    "api_base": "https://<worker_url>/?https://api.openframe.io",
    "app_base": "https://<worker_url>/?https://openframe.io",
    "api_url": "https://<worker_url>/?https://api.openframe.io"
  }
}

This will proxy all the HTTP requests through your Cloudflare worker, adding the appropriate CORS headers to the request.

Once done, OpenFrame should run and register with the website.

Thanks a lot for your help, i did everything you said and when i type openframe in the console nothing happens ( i don’t have the server error anymore!).

However as nothing happens i have tried DEBUG=* openframe and i get an error:
TypeError: Cannot read property ’ request’ of undefined.
If you have maybe an idea?

Thanks in advance!

Same is happening for me unfortunately. Is going to be any fix in this regard? I don’t know what to do in order to proceed. I have tried everything.