Installed, boots to black screen

Followed the instructions. Looks legit, connected. Website shows frame, green light, can push art to it, but it never has shown on the screen of the device.

Auto boots to openframe, I think. Cant be sure because the screen goes black. I can open up additional terminals, login and get same result.

stuck, please help.

Same here.

Black screen. Wireless is connected. Web app works fine also.

When I start openframe from the console I get an UnhendledPromiseRejectionWarning "Cannot read property ‘Download’ od undefined.

Hmm, I’m not sure what that error is, haven’t encountered that before… What version of the Pi and OS are you running?

To get out of the autoboot, hold the letter ‘n’ while the pi is booting (or when opening additional terminals). This should skip the autoboot.

Hi Jonathan,

I did that and ran openframe from console:

Got (node:1179) UnhandledPromiseRejectionWarning Unhandled Promis Rejection(rejection id:4) Typeerror: "Cannot read property ‘Download’ of undefined.

Im using a raspberry pi 3 model B with and used NOOBS_v2_4_2 to install raspian, does this make sense? Im new to raspberry pi.

Jorge

Yeah, that makes sense. Sorry it’s not working! I’m not sure what the error is, but haven’t tried an install with the latest version of Noobs. It’s also possible that the Openframe install is setup to grab the most recent version of node rather than a locked version, which could cause an error like this. Not sure when I’ll have time to investigate further, possibly this weekend.

Ok.

I will keep trying different things. Ill post results here.

Thank you very much for the time!

Did a fresh install with this image (2017-07-05-raspbian-jessie)

and now im getting a different error:

glsviewer app.cpp:250 assertion surface egl surface failed raspberry pi

still black screen but now i feel it didnt crash.

it reacts and goes to console when I change the type of stream, from image to shader for example and then to black again.

If I change to video i get “Have a nice day”

Ok, sounds like some progress… did you have a nice day :)? haha

It’s probably obvious, but the format of the artwork you’re trying to display must match the actual file at the URL of the artwork. If you enter an artwork URL pointing to an image and select ‘video’ as the format, it will fail (and tell you to have a nice day — that’s omxplayer, the underlying video utility, not openframe, that gives that message!)

Not sure what you’re trying, but I’d try some artworks that are known to work:

Shaders:

https://openframe.io/artwork/56d4e7fd9e1daa041f456a27

https://openframe.io/artwork/5727afd4c0006da8310e844f

Images:

https://openframe.io/artwork/56e5b48fa6b560d606184644

Great day, Jonathan!. Got it working.

Don’t know exactly how because I did several things.

Reinstalled several times.

Increase memory for GPU.

Install glslViewer manually.

Also because of manipulating it, I noticed why some streams don’t work. Maybe the file is no longer available, or is in a non suported format like gif, or a movie takes too long to load and can be confused with malfunctioning.

Thank you very much for this. It’s an amazing project.

Hey, glad you got this working! It shouldn’t be so tricky, but thanks for persisting. One of these I’ll try to find time to work on the kinks in the install now that lots of the various components have new versions.

I’m also receiving nothing but a black screen after installation. I had been using openframe for several months with no issues. A couple days ago, with no changes or other intervention to my RPi or anything installed on it, it simply stopped working. I spent a couple long days trying to get it back where it was, but to no avail. It was initially on Raspbian, but I decided to try NOOBS–I get the same result. Here are some details:

Environment:
OS: NOOBS 3.5.0 (9/15/20)
RPi 3b+
Running in CLI
GPU mem set to 256 (also tried 512)

Results:
When I attempted to run from within the desktop environment, I received an “inappropriate ioctl” error.
Running from CLI, it goes to a black screen.
Booting with “n” held down makes no difference whatsoever.

Any assistance you could provide would be helpful. I’m simply (and desperately) trying to get it back to where it was before it randomly flaked out.

Thanks

It looks like I’m back in business, so I wanted to share what I’ve done for anybody else searching the ioctl error or black screen. I’m wondering if my installing from the terminal within the desktop was causing some issues. Also, the slideshow installation was giving me an “unhandled promise rejection” error. Launching openframe first, stopping it, then installing the slideshow avoided the error.

  1. Download and install NOOBS.
  2. Set up wifi, etc., set GPU memory to 256 and set boot to CLI from the RPi config in the GUI, then reboot.
  3. Install openframe via script, then reboot.
  4. If you want the slideshow, launch openframe first, then stop it and install the slideshow extension. Reboot.

That’s what did it for me. I’m sure most of the reboots were unnecessary, but I wanted to have a nice, fresh start each time.

Thanks for all the hard work on this great project!