libGLESv2.so error

Has anyone encountered this error when trying to run openframe

glslViewer /tmp/shader.frag
glslViewer: error while loading shared libraries: libGLESv2.so: cannot open shared object file: No such file or directory

``

There’s an issue for this in GitHub. It has to do with the build of glslViewer that is packaged with Openframe, which needs to be updated for the latest version of Raspbian, as some deps have moved.

One workaround might be to manually build glslViewer on the Pi after installing openframe.

Thanks! I’ll try this

Manually building glslViewer worked. But I still get the below error about 50% of time when trying to load artwork.

glslViewer/tmp/shader.frag
Terminated

``

This is likely due to having your gpu memory set too low.

https://raspberrypi.stackexchange.com/questions/27468/raspberry-pi-2-1024m-increase-gpu-memory-to-512-at-least#28610