Soooo "The server is not available"... help? I need help

Hi!
For about a month ago my raspberry Pi booted openframe as usual and then suddenly stopped, no improvements have been made since.

As i type “openframe” into command line, all I get is “[o] ERROR: The server is not available.”

I’ve tried these possible solutions:

  • Using different kinds of wireless/wired ethernet connections
  • rebooting raspberry
  • tried to resetting the local frame data etc (openframe -r, same error message as listed above)
  • reinstalling openframe
  • reinstalled rasbian on raspberry pi, and I’ve followed the guide thoroughly.
    I have not seen anyone else on having this kind of error before? Where do you think the root of the problem is?

It is possible that I didn’t make a thorough reinstallment of rasbian, I might also have f**cked up the source code at some early point in my project.

All-knowing rasbian-geniuses are appreciated. I will honor thee with the lyrics of the song of my people, darude sandstorm.

Hey — not sure what’s up. This error should occur only if the API server can’t be reached. Here are some things to look at:

  • Verify that your frame is connected to the internet? (e.g., can you ping google.com)

- You can look at the the file ~/.openframe/.ofrc — it should include the following urls… if these are wrong, you’re using an older version of openframe, which will no longer work.

“network”: {

“api_base”: “https://api.openframe.io”,

“app_base”: “https://openframe.io

}

If the .ofrc file has the wrong urls, you can modify it directly or replace it with the original file from the repo.

It turned out to be some sort of hardware-mischief, it started rebooting at random and not behaving as it should. Thank you for your answer anyway! :slight_smile: